The current UI defaults to ES5. I would love it to default to the more efficient ES6.

Also, there are warning icons throughout about "missing semicolons" which don't matter. This particular warning should be removed. Even your example doesn't include semicolons out of the box.